Jump to content

Cannot install operating system on custom build. Help


Recommended Posts

I finished putting my computer together yesterday and I've spent well over twelve hours messing with different operating systems, formats, methods, and settings in the bios.


the specs: 

amd ryzen 7 1700 processor

corsair vengeance 8 gb ddr4 (2 sticks)

gtx 1050 ti GPU

tomahawk b350 mobo

EVGA 550 watt PSU

samsung 250 gb SSD


the farthest I got was I got to the "select language" screen in a copy of windows 7 professional, but the mouse and keyboard turned off and could not be used to interact with the PC at all after windows booted. USB ports and PS/2 connector all were useless after the bios gave way to the windows loading screen


i also tried windows 7 home premium ISO on a flash drive, I formatted it correctly to be bootable but it would cause a freeze on the "starting windows" logo


I Downloaded windows 10 and used Microsofts dedicated tool to create a bootable USB and that causes the PC to freeze after POST on the bios loading screen (MSI logo screen)



i just want to install literally any operating system. If anyone can figure out why the mouse and keyboard stop working at the choose language screen I'll go with the disc installation which seems most promising anyway

Link to comment
Share on other sites

51 minutes ago, λngelღмander said:

Don't want Linux


Not permanently, but to see if a portable Linux installation can boot fine.

Link to comment
Share on other sites

I had an issue with this before on my new rig. My problem was that windows 7 and my motherboard are actually incompatable because win7 doesnt natively support usb3.0 and intel stopped supporting win7 on their latest cpus. I would get to the install screen and lose mouse and keyboard. Took me around 12 hours to install windows (lol) i tried everything from a custom bootable usb, to my trusty disc, to a boot usb with modded drivers ect. What i did was use my brothers computer as a test mule and install windows using his computer as his hardware was compatible. Then i reinstalled that ssd into my rig and boom, i had an operating system. Then navagated through windows with a ps2 keyboard and got into asus' website and downloaded the fixes and patches needed. Sounds like you have the same or a variant of this problem, hope this helps. You can remove the left over install files from the test rig with ccleaner after youve done :)

Link to comment
Share on other sites

You need to enable the "Legacy USB" option in your BIOS. (also PS/2 Simulator option disabled).

If that doesn't work, try to run Windows in safe mode and install motherboard drivers from disc.

Link to comment
Share on other sites

I believe the problem is Ryzen (and Kaby Lake) only supports Windows 10. I could be wrong .

3 hours ago, Piterek said:

Take out one RAM stick and start the PC with one only. Check the second one too. 

This is also a good solution to try, you'd be surprised that even though you only need 1 stick of RAM to run the system, if 1 of the 2 plugged in is bad it will cause issues with everything

Link to comment
Share on other sites

I fixed it, I ended up managing to get a PS/2 keyboard to work and I installed windows using that. I had to install my MSI motherboard's drivers to make the mouse and keyboard work. The reason why it was having trouble was that the computer had no drivers for anything, it was a blank slate 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...