Jump to content
Brad Pitt

backpack.tf automatic help thread

Recommended Posts

advicebanana

I'm logged in to steam + bot 24/7 and it's never a problem for me. The next line should be "Offer handling ready" which indicates steam web is authenticated. If nothing comes out, we'd need to do some troubleshooting and add some additional logging. try replacing node_modules/steam/lib/handlers/user.js with this: http://pastebin.com/LEUTHmse and see what it spits out.

 

<botpath>>node bot

21:51:41 - info: backpack.tf automatic v0.0.13 starting

21:51:41 - info: Monday, October 20th, 2014

: Steam username:  (<accountname>)

: Steam password (hidden):

: Save password to file? (plain text):  (no)

21:52:05 - info: Connecting to Steam...

21:52:05 - debug: steam: connecting to 146.66.152.14:27018

21:52:05 - info: Settings saved to settings.json

21:52:05 - debug: steam: connected

21:52:05 - debug: steam: encrypt request

21:52:07 - debug: steam: handshake complete

21:52:09 - info: Connected to Steam on Monday, October 20th, 2014

21:52:09 - debug: steam: trying to authenticate via web...

21:52:11 - debug: steam: web authentication 403, retrying

21:52:12 - debug: steam: trying to authenticate via web...

21:52:13 - debug: steam: web login succesfull...

And then nothing happens.

Share this post


Link to post
Share on other sites
Zerr

Yes and yes, programs don't magically run when computers are offline. :D

Haha, was just wondering if it was somehow on your side! But ill have it on when im online!

Share this post


Link to post
Share on other sites
cares

nice try, but no

 

He was being vague, if he got the repo download he would've seen the same error, so I'm not sure.

Share this post


Link to post
Share on other sites
HusKy

 I will don't use bp.tf automatic because i don't want to give my passorwd.

 

 

The program is open sourced. It's safe.

Share this post


Link to post
Share on other sites
Brad Pitt

He was being vague, if he got the repo download he would've seen the same error, so I'm not sure.

no, he wouldn't have got to the prompt, he said after entering user/pass he got the error. just saying. :D

 

And then nothing happens.

So that means the web login does work, but it's unable to retrieve your steam api key somehow. can you go to http://steamcommunity.com/dev/apikey ? is there a key listed / error message ?

Share this post


Link to post
Share on other sites
advicebanana

no, he wouldn't have got to the prompt, he said after entering user/pass he got the error. just saying. :D

 

So that means the web login does work, but it's unable to retrieve your steam api key somehow. can you go to http://steamcommunity.com/dev/apikey ? is there a key listed / error message ?

I do see my API key there. I do not remember configuring the bot with the API key. Does the script retrieve it? What if it still wants to use my test account's API key?

 

Edit: I just checked my test account's API key that I do not remember getting. There is one registered for localhost though.

Share this post


Link to post
Share on other sites
Brad Pitt

I do see my API key there. I do not remember configuring the bot with the API key. Does the script retrieve it? What if it still wants to use my test account's API key?

 

Edit: I just checked my test account's API key that I do not remember getting. There is one registered for localhost though.

 replace node_modules/steam-tradeoffers/index.js with http://pastebin.com/rvU4Eh6g and try again? i added a few log entries in there so we can hopefully figure this out ^_^

Share this post


Link to post
Share on other sites
advicebanana

I have this in the log over and over:

debug: offers: fetching api key...
debug: offers: no api key found, registering...

 

The API key after all. I do have one though. A workaround might be to just force an API key in the settings.

Share this post


Link to post
Share on other sites
Brad Pitt

I have this in the log over and over:

 

The API key after all. I do have one though. A workaround might be to just force an API key in the settings.

I added you to troubleshoot further, I'd rather fix the issue and keep the "automated" api keys than force entry of an api key and confuse people =) keeping things simple is much better in this case, i think!

Share this post


Link to post
Share on other sites
Julia

Don't download the full package if you're not running windows, build from the source instead. The full package is for windows only.

Thanks, that worked.

Share this post


Link to post
Share on other sites
Crabtor Who

Hi I installed it, sounds great however I seem to have a problem. When it started, I got a trade, but started getting these messages.

steam: 1 trade offer pending.
16:28:23 - info: [175737985] Checking offer from 76561198008432001...
16:28:29 - info: [175737985] Asked: 0.11 refined (The Kritzkrieg). Offered: 0.11 refined
16:28:29 - error: [175737985] Error: Insufficient privileges accepting offer - refresing web cookies...
16:28:30 - debug: steam: web authentication 403, retrying
16:28:32 - info: Offer handling ready.
16:28:32 - debug: Heartbeat sent to backpack.tf
16:28:33 - error: [175737985] Error: Insufficient privileges accepting offer - refresing web cookies...
16:28:33 - debug: offers: 1 pending, 0 new received.
16:28:34 - debug: steam: web authentication 403, retrying
16:28:35 - info: Offer handling ready.
16:28:36 - debug: Heartbeat sent to backpack.tf
16:28:36 - error: [175737985] Error: Insufficient privileges accepting offer - refresing web cookies...

It kept going. I tried to accept it manually, but then I got told as I'd logged in from a new computer I'll have to wait 7 days to trade again!  :(

 

Any thoughts? Suggestions?

Share this post


Link to post
Share on other sites
cares

Hi I installed it, sounds great however I seem to have a problem. When it started, I got a trade, but started getting these messages.

 

It kept going. I tried to accept it manually, but then I got told as I'd logged in from a new computer I'll have to wait 7 days to trade again!  :(

 

Any thoughts? Suggestions?

 

You'll have to wait 7 days for steamguard.

Share this post


Link to post
Share on other sites
Crabtor Who

You'll have to wait 7 days for steamguard.

 

Does everyone else have that problem? Also randomly someone was just able to trade with me in a regular trade (not a trade request), so don't know what's going on there

Share this post


Link to post
Share on other sites
Brad Pitt

Does everyone else have that problem? Also randomly someone was just able to trade with me in a regular trade (not a trade request), so don't know what's going on there

Do you have steam guard enabled? In theory it shouldn't be putting you in a restriction if you do since it's coming from a known IP or something. If you don't have steam guard enabled then you have to wait 7 days, might as well enable it now so you don't run into more issues in the future.

Share this post


Link to post
Share on other sites
Crabtor Who

Do you have steam guard enabled? In theory it shouldn't be putting you in a restriction if you do since it's coming from a known IP or something. If you don't have steam guard enabled then you have to wait 7 days, might as well enable it now so you don't run into more issues in the future.

 

Yeah I do. To be honest I don't even think about SteamGuard, but just double checked it now to see if it was active and it is. I've been using this computer for steam - well since I built this computer about 3 years ago lol. Although if I was just able to do a trade manually, then that can't be right either... 

 

A tiny bit confused... lol

Share this post


Link to post
Share on other sites
Crabtor Who

Ok take 2 : 

17:23:08 - info: steam: 1 trade offer pending.
17:23:09 - info: [175798986] Checking offer from 76561198110334304...
17:23:13 - info: [175798986] Asked: (The Cozy Camper). Offered: 0.11 refined
17:23:13 - info: [175798986] Skipping: This offer does not match any backpack.tf
 listing.
17:23:30 - debug: offers: 1 pending, 0 new received.
17:23:51 - debug: offers: doing API call GetTradeOffers/v1: Error: connect ETIME
DOUT
17:23:51 - warn: Error: connect ETIMEDOUT receiving offers, re-trying in 10s.
17:24:40 - debug: offers: 1 pending, 0 new received.
17:25:11 - info: steam: 0 trade offers pending.
17:25:40 - debug: offers: 0 pending, 0 new received.

At this point I didn't want to lose the trade and steam let me do it manually - I wish valve was consistent in what it moans about lol

Share this post


Link to post
Share on other sites
cares

Ok take 2 : 

17:23:08 - info: steam: 1 trade offer pending.
17:23:09 - info: [175798986] Checking offer from 76561198110334304...
17:23:13 - info: [175798986] Asked: (The Cozy Camper). Offered: 0.11 refined
17:23:13 - info: [175798986] Skipping: This offer does not match any backpack.tf
 listing.
17:23:30 - debug: offers: 1 pending, 0 new received.
17:23:51 - debug: offers: doing API call GetTradeOffers/v1: Error: connect ETIME
DOUT
17:23:51 - warn: Error: connect ETIMEDOUT receiving offers, re-trying in 10s.
17:24:40 - debug: offers: 1 pending, 0 new received.
17:25:11 - info: steam: 0 trade offers pending.
17:25:40 - debug: offers: 0 pending, 0 new received.

At this point I didn't want to lose the trade and steam let me do it manually - I wish valve was consistent in what it moans about lol

 

Steam is probably having its daily share of issues and downtime.

Share this post


Link to post
Share on other sites
Crabtor Who

Woo success!

 

22:32:09 - debug: offers: 0 pending, 0 new received.

22:32:35 - info: steam: 1 trade offer pending.

22:32:35 - info: [176007334] Checking offer from 76561198118869038...

22:32:37 - info: [176007334] Asked: 0.11 refined (The Eyelander). Offered: 0.11

refined

22:32:41 - info: steam: 0 trade offers pending.

22:32:41 - info: [176007334] Accepted offer.

22:33:09 - debug: offers: 0 pending, 0 new received.

Share this post


Link to post
Share on other sites
BlueRain

Try to re-install from the full package in a new folder, you can move over your settings.json so you don't need to re-authenticate

 

Seems I'm missing a step here.

 

 

I did the following ('lazy way'):

- Installed Node.js

- Updated OpenSSL, normal one

- Extracted the pre-packaged version in a folder

- Did double click on automatic bat, then got the error (http://i.imgur.com/J1OCyyS.png)

 

 

Then I tried the second option, ('Power users')

- Installed Python (2.7)

- Forked ursa, node-gyp and the bp.tf automatic repository to my GitHub account , then tried to install them

^ Been dealing with an error behind another, apparently I should downgrade python to 2.6  and Visual studio to 2010/2012, to install node-gyp... still on it. Ursa and node-gyp are required for both installation ways, correct?

Share this post


Link to post
Share on other sites
Brad Pitt

Seems I'm missing a step here.

 

 

I did the following ('lazy way'):

- Installed Node.js

- Updated OpenSSL, normal one

- Extracted the pre-packaged version in a folder

- Did double click on automatic bat, then got the error (http://i.imgur.com/J1OCyyS.png)

 

 

Then I tried the second option, ('Power users')

- Installed Python (2.7)

- Forked ursa, node-gyp and the bp.tf automatic repository to my GitHub account , then tried to install them

^ Been dealing with an error behind another, apparently I should downgrade python to 2.6 and Visual studio to 2010/2012, to install node-gyp... still on it. Ursa and node-gyp are required for both installation ways, correct?

For the lazy option, all you need to install is OpenSSL -- what version of node are you running ?

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...